Proteger servidor PPPOE (por dentro da rede)

Todos que configuram um servidor pppoe no mikrotik sabem que a configuração é bem simples,
via de regra, o cara escolhe um bloco de ip e seta o primeiro ou o ultimo sendo o endereço do servidor ok,

exemplo:

192.168.0.1 (servidor pppoe)

192.168.0.2-192.168.0.254 (pool de endereços)

so que desta forma o endereço, 192.168.0.1 esta fisicamente acessível aos usuários de nossa rede,
vamos dificultar as coisas,

192.168.0.0 (isso mesmo, 0.0 pro servidor, “isso no profile” ok)
192.168.0.2-192.168.0.254 (continua o mesmo pool)

ao cliente conectar, verifique que o gateway dele sera o 192.168.0.0, o que dificultará ataques internos
já que as nossas redes são cheias de Hackers (script kidies, pra ser honesto), tentando sacanear o tempo todo.

Fica ai a dica.

O que difere Epon e GPon ?

As Redes Ópticas Passivas mais utilizadas atualmente são as GEPON e GPON. Ambas não necessitam de eletricidade no meio de transmissão e são ideais para a oferta de triple play (tv + telefonia + internet).
rede PON (Passive Optical Network ou Rede Óptica Passiva) é uma evolução da arquitetura de rede ponto multiponto que tem como principal característica a não utilização de energia elétrica percorrendo seu meio físico. Por isso, leva o nome de rede óptica passiva, ou seja, seus elementos responsáveis pela distribuição do sinal (splitters) são totalmente passivos.

O sistema de transmissão de uma rede PON apresenta três componentes fundamentais:

1. Terminal de linha óptica (OLT – Optical Line Terminal)

É responsável pela gerência do sistema e pelo provimento de uma interface ao restante da rede, podendo ser localizada na central ou remotamente. O sinal óptico é transmitido pela OLT através da rede de distribuição óptica (ODN – Optical Distribution Network).

2. Unidade de rede óptica (ONU – Optical Network Unit) ou Terminal de linha óptica (ONT – Optical Network Terminal)

É responsável pelo recebimento do sinal óptico e conversão em sinal elétrico. É chamado de ONT quando se encontra na casa do assinante como um modem; já ONU é o termo designado quando ele se encontra no meio da rede, que é o caso de quando é feito um FTTB, FTTC, FTTN, entre outros.

3. Rede de distribuição óptica (ODN – Optical Distribution Network)

É a parte da rede óptica entre a OLT e a ONT, composta por fibra óptica e passivos ópticos. Esses componentes são divididos entre ativos e passivos ópticos, conforme descrito abaixo:

-Ativos: OLT e ONT, por se tratarem de componentes ópticos e eletrônicos ativos;

-Passivos: constitui todos os outros itens da rede, tais como divisores, conectores, adaptadores, caixas de emenda, pontos de terminação óptico, etc. As tecnologias mais utilizadas atualmente em redes ponto multiponto são o EPON/GEPON e GPON, sendo:

  • EPON: Ethernet Passive Optical Network, mais conhecida no mercado nacional como GEPON (Gigabit Ethernet Passive Optical Network);
  • GPON: Gigabit Passive Optical Network.

 

EPON é um padrão desenvolvido pelo Institute of Eletrical and Eletronics Engineers (IEEE), através de uma iniciativa do grupo “Ethernet in the first mile” – EFM (Ethernet na primeira – ou última – milha). A organização responsável pelo EPON é o IEEE e suas especificações estão definidas no IEEE 802.3ah.

A velocidade de transferência no EPON é simétrica, de 1,25Gbps, ou seja, possui essa velocidade tanto no sentido de downstream quanto no upstream. No sentido de downstream no EPON, os pacotes da OLT são enviados via broadcast para todas ONTs/ONUs, como é padrão no Ethernet, a ONT/ONU seleciona qual pacote é seu e o resto descarta. No sentido de upstream o comportamento do EPON é similar a uma arquitetura ponto a ponto: o EPON adota o TDM (Multiplexação por Divisão de Tempo), ou seja, cada ONT/ONU transmite os quadros Ethernet para a OLT com intervalos de tempo de transmissão diferentes, atribuídos pela OLT.

GPON é um padrão definido pelo International Telecommunication Union (ITU-T) e suas especificações e recomendações estão definidas no G.984.x (G.984.1, G.984.2, G.984.3, G.984.4, G.984,5, G.984,6). As velocidades de transferência no GPON são assimétricas, ou seja, diferentes nos sentidos de downstream e upstream. No sentido de downstream a velocidade de transferência é de 2,5Gbps, já no sentido de upstream a velocidade de transferência é de 1,25Gbps.

O comportamento dos pacotes de dados nos sentidos de downstream e upstream são semelhantes aos do EPON, o que difere é somente que no GPON o formato do frame (quadro de informação) contém células ATM.

 

Fibra Óptica I: Arquitetura PON

Topologias

Há muitas topologias que podem ser a aplicadas a uma Rede Óptica de Acesso como: Topologia Barra, Estrela, Anel, Árvore.

Topologia Barra: provê uma conectividade ponto-multiponto entre OLT e ONT/ONU, mas qualquer falha no enlace principal causa a desconexão dos usuários.

Figura 12: Representação Topologia Barra

Topologia Estrela: provê uma conectividade ponto-a-ponto entre OLT e ONT/ONU. Esta topologia permite entrega de banda dedicada de altas taxas aos usuários finais e também possui um baixo custo em operação, administração e manutenção (OAM).

Figura 13: Representação Topologia Estrela

Topologia em Anel: esta arquitetura oferece a vantagem ponto-multiponto da OLT para a ONT/ONU. Permite facilmente implementação de mecanismos de proteção – enlace com redundância – mas possui dificuldades para as funções de OAM.

Figura 13: Representação Topologia Estrela

Topologia Árvore: arquitetura ponto-multiponto que oferece a vantagem de infra-estrutura compartilhada entre todos os usuários, possuindo assim uma importante redução nos custos de implementação e manutenção na rede de acesso. Esta arquitetura é uma das mais difundidas nos estudos relacionados à Rede PON. (CHOCHLIOUROS).

Figura 15: Representação Topologia Árvore

Equipamentos

Em uma rede óptica PON, os elementos passivos ficam localizados na planta externa, onde ocorre a distribuição óptica. Estes elementos são: cabos ópticos, divisores passivos, conectores, acopladores. Os únicos elementos ativos são a OLT na central e, a ONU ou ONT, que ficam próximos ao cliente. Ao se implantar uma rede podem ser utilizadas diversas topologias, e para uma rede PON podem ser aplicadas as topologias apresentadas a seguir.

OLT – Terminal de Linha Óptica

A OLT (Optical Line Terminal) Terminal de Linha Óptica normalmente instalada dentro da Central da Operadora e controla o fluxo de informações bidirecional para a ONT/ONU. Normalmente à distância da OLT a ONT/ONU é de 20 km e a mesma controla mais de uma ONT, a figura 16 mostra um exemplo de uma OLT que controla 4 redes passivas independentes, como cada rede PON possui 32 ONTs, então uma OLT atende um total de 128 ONTs onde se viabiliza serviços para os usuários finais e controla a qualidade do serviço (QoS) e o SLA (Service Level Agreement), entre outras tarefas.

Figura 16: Atendimento de quatro redes PON por uma OLT

(Fonte: KEISER, 2006)

Uma rede PON uma o comprimento de onda de 1490 nm para o tráfego de voz e dados e 1550nm como comprimento de onda para transmissão de vídeo, isso no sentido downstream da OLT para a ONT ou ONU, o que é evidenciado na figura 17. E para tráfego upstream o comprimento 1310 nm. Elementos passivos são utilizados ao longo do enlace como os acopladores WDM e Splitters. Os primeiros na multiplexação dos comprimentos de onda em upstream e downstream e, os últimos na divisão do sinal óptico.

Figura 17 – Representação dos comprimentos de Onda para Tx e Rx na rede PON

(Fonte: Huawei)

Dependendo da rede PON utilizada e equipamentos, as taxas de downstream e upstream operam a 155 Mbit/s, 622 Mbit/s, 1,25 Gbit/s ou 2,5 Gbit/s, dependendo a taxa pode ser simétrica ou assimétrica (KEISER, 2006).

Figura 18: Exemplo de uma OLT

(Fonte: ERICSSON)

ONU – Unidade de Rede Óptica

A OLT se conecta a ONU (Optical Network Units) ou ONT (Optical Network Terminal) que é o equipamento que provê a interface entre os dados do cliente, vídeo e redes de telefonia.

O Terminal de Rede Óptica fica instalado diretamente na casa do cliente e permite que o cliente escolha a sua taxa de banda larga, pois dispõe de diversas tecnologias para atendimento entregando na casa do cliente a taxa que ele achar necessária para a melhor qualidade dos seus serviços. Este equipamento permite a alocação de banda dinâmica, ou seja, transmite em pequenos espaços de tempo que são controlados pela OLT tendo assim uma intensa utilização da banda alocada. Existe uma imensa variedade de ONTs no mercado, de diversos fabricantes, com funcionalidade e configurações para atender diversas larguras de banda (KEISER, 2006).

Figura 19 Modelo de ONU ADC

(Fonte: ADC)

ONT – Terminal de Rede Óptica

A ONU é um equipamento instalado ao ar livre. Juntamente é instalada uma bateria reserva para eventuais quedas de energia e medidas de proteção do equipamento devem ser tomadas quanto a mudanças climáticas, a atuação de vândalos. A ligação da ONU até o equipamento do cliente pode ser realizada através de cabo par metálico (xDSL), cabo coaxial, ligação de fibra óptica independente ou ainda uma conexão sem fios.

Além de realizar a interface da OLT com o cliente, a ONU também é responsável pela multiplexação e demultiplexação dos serviços cliente/operadora e operadora/cliente, e mais o fornecimento de energia. Também existem diversas ONU no mercado e a mesma deve ser adquirida de acordo com a aplicação FTTx.

Figura 20: Modelo de ONT Zyxel

(Fonte: Zyxel)

Divisor Óptico

Nos primeiros sistemas de fibras ópticas, o divisor óptico não era necessário visto que se transportava o sinal óptico apenas entre dois pontos. Agora muitos dos serviços requerem acesso a diversos terminais, e um divisor óptico conectado a essa rede possibilita a divisão do sinal em 1×4, 1×8, 1×16, 1×32 ou 1×64, ou seja, uma única fibra é capaz de ter mais 64 fibras de saída para atendimento após passar por um divisor óptico, chamado também de Splliter. A capacidade de divisão do splitters depende muito do seu processo de fabricação.

Figura 21: Divisor óptico 1×32 fibras, fabricante SENKO

(Fonte: Senko)

Transporte

Protocolo ATM

No fim da década de 80 e inicio da década de 90, foi padronizado o protocolo ATM por órgãos internacionais CCITT (Commite Consultative International on Telecommunicatons and Telegraph – Comitê Internacional Consultivo de Telecomunicações e Telegrafia), hoje ITU-T (Europa) e ANSI – American National Standards Institute (EUA). Formado por uma estrutura de 53 bytes, como pode ser visto na figura 23, sendo 5 bytes para o cabeçalho e 48 para payload (campo reservado para informações úteis, dados), cada célula ATM enviada para a rede contém uma informação de endereçamento no seu cabeçalho que estabelece uma conexão virtual entre origem e destino. Como o protocolo é orientado a conexão, abrange a rede de dados com capacidade para transmissão de serviços confiáveis e de qualidade garantida a partir de um único meio de acesso. A tecnologia ISDN ((Integrated Services Digital Network – Redes Digitais Serviços Integrados) foi aplicada à banda larga, pois além dos caminhos fixos que as células seguem pelos canais virtuais até o seu destino. O protocolo ATM também possui mecanismos de controle de tráfego, o que melhorou a disponibilidade de banda nesta época (FILHO, 2003).

Sendo um protocolo de transporte nas redes A/BPON e GPON definidos na Recomendação ITU-T G983.1 (2005), tem como principal característica a utilização de células de comprimento fixo em 53 bytes. No sentido downstream as células são transmitidas a todas as ONUs, sendo que o quadro de dados consiste em 54 células mais 2 células para PLOAM (Physical Layer Operation, Administration and Maintenance – Operação, Administração e Manutenção da Camada Física), demonstrado pela figura 22.

No sentido Upstream o quadro consiste em 53 pacotes de dados, cada um com 56 bytes. Como a célula tem 53 bytes, os 3 restantes são utilizados para a sincronização com a OLT. Neste sentido todos os usuários utilizam no canal de acesso a multiplexação TDMA (Time Divison Multiplexing Access) para evitar possíveis colisões no trafego de informações. (CHOCHLIOUROS)

Figura 22:Formato Básico de quadro ATM para downstream e upstream

(Fonte: CHOCHLIOUTROS)

Figura 23:Representação de uma Célula ATM

(Fonte: KEISER, 2006)

Protocolo GEM – GPOn Encapsulation Method

O método de encapsulamento GPON é semelhante ao ATM, apenas usa um comprimento de quadros de tamanho variável enquanto que no ATM era fixo. Este protocolo também é orientado a conexão e pode ser gerenciado utilizando as mesmas metodologias de transporte ATM.

O GEM permite que se trabalhe com diversos serviços (ATM, TDM e Ethernet) num quadro de dados de 1500 bytes de comprimento. Se a ONT possui um pacote de envio de dados maior que 1500 bytes, a mesma possui a função de quebra deste pacote para envio somente do tamanho de quadro permitido. O equipamento de destino é o responsável pela junção destes pacotes para transpor ao pacote original.

O quadro GEM consiste em quatro segmentos de cabeçalho e um segmento para envio de dados, que pode ser visualizado na figura 24.

O primeiro segmento PLI (Payload Length Indicator – Quantidade de carga útil) indica em bytes o tamanho do payload GEM. O Port ID traz a informação de identificação da porta e que fluxo de serviço o segmento pertence. O PTI (Payload Type Indicator – Indicador do Padrão de Carga Útil) mostra se o quadro é o fim de informações de determinado usuário, se o fluxo de tráfego está congestionado ou se o payload GEM contém informações de operação e manutenção (OAM). A verificação cíclica de redundância (CRC – Cyclic Redundancy Check) controla a taxa de erro de bit no cabeçalho. Por fim o segmento de Payload onde constam as informações a serem transmitidas (KEISER, 2006).

Uma das principais vantagens do método GEM é a forma eficiente de encapsulamento e fragmentação de pacotes de informações do usuário, a gestão adequada de múltiplos fluxos de serviços de diferentes ONTs em um link comum de fibra óptica permite o envio de fragmentos das informações de forma independente e com recuperação confiável da informação ao chegar no destino.

Figura 24: Estrutura do Protocolo GEM

(Fonte: KEISER, 2006)

Formato de Quadro Downstream e Upstream GPON

O tráfego de informações pelo GPON consiste em transmissões sucessivas de uma ou mais ONTs. A importante questão é sua forma de comunicação que abrange todos os tipos de serviços (por exemplo, ATM, TDM e Ethernet) de forma eficiente, determinado no método de encapsulamento de dados GEM (Gpon Frame Format – Formato de Quadro GPON), figura 25. Este método é baseado em uma versão modificada da Recomendação ITU-T G7041 Processo Genérico de Elaboração (Generic Framing Procedure), que informa sobre o envio de pacotes IP sobre SDH. O comprimento do quadro GPON é de 125 µs fixo.

A Recomendação ITU-T G984.3 descreve a convergência de transmissão equivalente a camada 2 (camada de transmissão de dados), em referência ao modelo OSI, para o formato de quadro GPON, os meios de comunicação do protocolo de controle de acesso, operações e controle de manutenção e, as informações do método de encriptação.

O quadro de downstream GPON consiste num bloco de controle físico (PCB – Physical Control Block) e um payload composto por um segmento ATM (dados encapsulados em ATM) e um segmento GEM. A seção PCB contém as informações de controle e gerenciamento da rede.

No sentido de download o PCBd (Bloco de Controle Físico em Download), contém as informações de controle e gerenciamento da rede sendo: sincronização com relógio interno em 8Khz, correção de erro, encriptação, operação e manutenção de alertas e alocação de N intervalos de transmissão das ONT/ONUs.

No sentido de upload é utilizado o sincronismo proposto no sentido download, assim cada ONU mantém o mesmo número de transmissões. O tamanho de comprimento do quadro é mantido em 125 µs. Cada quadro de envio upstream contem quatro campos PON e um campo de comprimento variável onde contem as informações para transmissão, sendo:

Figura 25: Formato GPON de Downstrem e Upstream

(Fonte: CHOCHLIOUROS)

  • PLOu (Physical Layer Overhead) – Camada Física de Sobrecarga: trabalha com informações de operação da camada, sincronismo no upstream de dados.
  • PLOAMu (Physical Layer Operation, Administration and Management) – Camanda de Operação e Manutenção: responsável pelas funções de ativação de uma ONT e notificações de alarme. Possui 13 bytes onde são configuradas mensagens determinadas por recomendação G983.1 e também para deteção e correção de erros de bits no processo upstream, através do CRC (Cyclic Redundancy Check).
  • PLSu (Power Leveling Sequence) – Seqüência de Nivelamento de Potencia: Campo onde se especifica o nível de potencia do laser ONT visto pela OLT, assim a OLT pode ter o controle sobre a gama óptica da ONT.
  • DBRu (Dynamic Bandwith Report) – Informação de Banda Dinâmica por Seção: assim a OLT tem o controle de operação de banda sobre as ONTs, também sendo protegido contra redundância.
  • Payload: campo que contem as informações a serem transmitidas.

Ainda no upstream é preciso se reservar uma banda de guarda, demonstrado na figura 26, entre os pacotes de transmissão das diferentes ONTs para que ocorra o menor erro de bit possível mediante colisões de pacotes (CHOCHLIOUROS; KEISER, 2006).

Figura 26: Tráfego US + Banda de Guarda

(Fonte: KEISER, 2006)

Multiplexação

WDM (Wavelenght Divison Multiplexing – Multiplexação por Divisão do Comprimento de Onda)

Desenvolvida por volta de 1990, o WDM consiste em uma tecnologia utilizada para multiplexação de dados onde é possível agregar diversos sinais de luz com comprimentos de ondas diferentes em uma única fibra. O grande objetivo de uma multiplexação é compartilhar o meio. Um ponto importante ao se implementar o sistema WDM, figura 27, é que os comprimentos de onda (ou freqüências ópticas) em WDM devem ser espaçados adequadamente para evitar interferência entre canais adjacentes.

O WDM possui algumas características principais:

  • Aumento da capacidade de transmissão da fibra já implantada, utilizando assim toda a largura de banda disponível na fibra e permitir futuras atualizações e implementações em uma Rede PON. Permite migrações de 622 Mbit/s para 2,5 Gbit/s e após para 10 Gbit/s sem a necessidade de maiores investimentos na planta atual.
  • Transparência: um canal óptico multiplexado em WDM pode transportar qualquer formato de transmissão independente pela fibra, usando diferentes comprimentos de ondas os sinais a serem transmitidos podem possuir formatos e taxas de bit diferentes (sinais analógicos, digitais, síncronos ou assíncronos) sem a necessidade de uma estrutura comum. Isso é uma característica importante para serviços triple-play (dados, voz e vídeo simultâneos) PON.
  • Transmissão Bidirecional: os canais por comprimentos de onda são enviados em qualquer direção pela fibra. No caso do PON os comprimentos 1490nm e 1550nm para tráfego downstream e 1310 para upstream.
  • Roteamento do comprimento de onda: não é utilizado meio elétrico para a distribuição do sinal óptico, em alguns nós intermediários da rede são alocados os acopladores ópticos para combinar e separar os diversos comprimentos de onda.

Figura 27: Sistema WDM

(Fonte: WOODWARD, 2005)

Cada canal de um multiplexador WDM é projetado para transmitir determinados comprimentos de onda. O multiplexador funciona muito bem como um acoplador no inicio da fibra e como um filtro na extremidade contrária, são fabricados para serem usados em pares.

A maioria dos sistemas WDM operam em fibras monomodo com diâmetro aproximadamente de 0,8nm de núcleo, e podem ser divididos em:

  • Convencional (WDM)
  • Grosseiro (CWDM)
  • Denso (DWDM)
  • Ultra Denso (UDWDM)

O princípio de funcionamento do WDM é o mesmo para o CWDM, onde a informação é agrupada em até 18 canais entre os comprimentos de onda de 1270 nm e 1610 nm, e a distância entre os canais é de 20 nm. Já os sistemas DWDM (Dense Wavelength Division Multiplexing – multiplexação densa por comprimento de onda) segundo a ITU, podem combinar até 64 canais em uma única fibra. No entanto, pode-se encontrar, na prática, sistemas DWDM que podem multiplexar até 128 comprimentos de onda, chegando a ordem de tráfego de Tbit/s (por exemplo: nos 128 comprimentos de onda sejam carregados cada um deles com STM-64 ~ 10 Gbit/s em sinal digital). Além disso, foram realizados alguns testes que provaram ser possível a multiplexação de até 206 canais (WOODWARD, 2005)

CWDM (Coarse Wavelenght Division Multiplexing – Multiplexação Grosseira por Divisão do Comprimento de Onda)

Com o desejo de se conseguir baixar os custos nas redes ópticas a ITU-T lança em 2002 a Recomendação G694.2 onde se padroniza um grid espectral para CWDM. A tecnologia CWDM trabalha na faixa de espectro de 1270nm a 1610nm permitindo 18 canais com espaçamento de 20nm entre os mesmos, exemplificado na figura 28.

Figura 28: Espaçamento entre canais CWDM

O sistema CWDM apresenta interfaces ópticas com flexibilidade para serem empregadas em conexões ponto-a-ponto sendo a taxa de transmissão permitida até 40 km de 1,25 Gbit/s e até 80 km 2,5 Gbit/s.

DWDM (Dense Wavelenght Division Multiplexing – Multiplexação Densa por Divisão do Comprimento de Onda)

O padrão da indústria sobre o DWDM segundo a ITU-T G694.1, é o espaçamento de 0,8nm por canal ou 100Ghz, mas também enumera-se o espaçamento de 50 Ghz, isto mostra que os usuários são divididos na freqüência e não no tempo. Utiliza os comprimentos de onda entre 1525nm e 1620 nm. É importante notar que, como o espaçamento ou a largura de cada canal diminui, a largura espectral torna-se menor, isto é relevante porque o comprimento de onda deve se manter estável no tempo para não interferir no canal adjacente. Assim altas taxas e eficiência de banda são proporcionadas as Redes MAN e WAN.

A maioria das tecnologias para multiplexação e demultiplexação dos diversos comprimentos de onda se baseiam em comprimentos de onda plana permitindo assim uma boa integração entre os diversos equipamentos. Além disso dois outros pontos críticos: a sensibilidade de polarização e sensibilidade térmica do laser, devem ser cuidadosamente considerados. Assim o nível de polarização do laser entre a OLT e ONU deve se manter constante para que não ocorra perda de comunicação entre os mesmos e o controle de temperatura do laser de transmissão é fundamental para que não ocorra dispersão do sinal fora da janela de transmissão DWDM. Devido a essas particularidades os sistemas DWDM são mais caros que os CWDM.

Uma das principais técnicas de multiplexação dos diversos sinais de luz é o AWG (Arrayed Wavelenght Routing – Grades de Guias de Onda), apresentado na figura 29, é constituído de camadas dopadas de sílica sob um substrato de silício com baixa perda de inserção (tipicamente <0,05 dB, independente do número de λ) e possui alta eficiência de acoplamento da fibra, seu principio de funcionamento baseia-se em difração da luz. (HANDBOOK)

Figura 29: Grades de Guias de Onda

(Fonte: HANDBOOK)

O AWG é composto por terminais de entrada e saída. Como exemplificado na figura 30, a luz de incidência no AWG através do acoplamento da fibra se propaga pela região do espaço livre e ilumina a grade com uma distribuição Gaussiana, onde cada comprimento de onda sofre mudança de fase e são enviados a folha de saída para sua nova orientação e retransmissão. Utilizado principalmente em enlaces estáticos P2P, ou flexível, com um único canal OADMs.

Figura 3 – Comportamento do Sinal no Filtro AWG

(Fonte: GTA-UFRJ)

Uma importante característica do AWG é a utilização de uma livre faixa espectral FSR (Free Spectral Range), que define a periodicidade do comprimento de onda na fibra. A utilização de filtros AWG em cascata melhora o fator de escala, a luz irá transmitir um comprimento de onda e refletir todos os outros. Aplicando-se esse cascateamento em um cenário estático o fornecimento de λ dedicados, através dos AWG do nó passivo, melhora o roteamento de banda por ONU. ONU idênticas utilizam mesmo λ no Upstream, assim necessita-se de técnicas TDMA.

U-DWDM (Ultra Dense Wavelenght Division Multiplexing – Multiplexação Ultra Densa por Divisão do Comprimento de Onda)

Este tipo de multiplexação ainda encontra-se em estudo sendo um dos próximos passos para a área de comunicações ópticas. O que sabe-se segundo publicação GTA-UFRJ é que:

“Esta tecnologia combina 128 ou 256 comprimentos de onda em uma única fibra óptica, sendo que cada comprimento de onda teria uma taxa de transmissão de 2.5 Gbit/s, 10 Gbit/s e até 40 Gbit/s. No U-DWDM os canais estão espaçados de 10 GHz, o que corresponde a 0.08 nm.”

QoS (Quality of Service – Qualidade de Serviço)

Um sistema de telecomunicações utilizará os procedimentos de gestão de desempenho para monitorar e controlar os parâmetros-chave que são essenciais para o bom funcionamento de um rede, a fim de garantir uma QoS específica para usuários da rede.

Um dos desafios mais importantes da rede PON é oferecer qualidade de Serviço (QoS). Os recursos utilizados na rede para melhor eficiência da mesma tratam, preferencialmente os parâmetros para se garantir a eficiência de tráfego e priorização de determinados tipos de serviços, assim são utilizadas classes de diferenciação de serviços e também assinantes.

Alguns parâmetros observados incluem a função de monitoramento remoto, supervisão de erros, relatório estatísticos referente a falhas da ONT/ONUs, além de parâmetros que podem ser monitorados no nível físico como de erro de bit taxa e os níveis de potência óptica, tanto OLT e os ONTs.

Aplicações atuais de serviços multimídia utilizam o melhor esforço da largura de banda de uma rede provendo a prestação do serviço (QoS) ou aplicação requisitada pelo assinante.Por exemplo, a comunicação interativa de alta qualidade requer forma de um atraso de menos de 150 ms e menos de 1% de perda de pacote. Por outro lado, uma sessão de distribuição de streaming VoD (Vídeo sob Demanda) tem atrasos menos rigorosos. A partir do ponto de vista do prestador de serviços, prover QoS implica a construção de uma rede IP gerenciada que possa transferir as informações de mídia de um modo controlado e prioritário (LIN, 2006).

Utilizando o controle de QoS na rede a Largura de Banda disponível é melhor dividida através das priorizações dos serviços. Por segurança o tráfego de downstream de pacotes pela fibra contém em seu cabeçalho a identificação da ONU correspondente. Além disso o Padrão GPON utiliza um mecanismo de criptografia em enlaces ponto-a-ponto sendo conhecido por AES (Advanced Encryption Standard). A criptografia AES utiliza chaves de codificação de 128, 192, 256 bits, o que se torna extremamente difícil de se decifrar (KEISER, 2006).

QOS – 2016

Segue conforme prometido:


/ip firewall mangle
add action=mark-connection chain=postrouting comment=UPLOAD new-connection-mark=uploadconn out-interface=WAN 1
add action=mark-packet chain=postrouting connection-mark=uploadconn new-packet-mark=uploadp
add action=mark-connection chain=prerouting comment=DOWNLOAD in-interface=WAN 1    new-connection-mark=downloadconn
add action=mark-packet chain=prerouting connection-mark=downloadconn new-packet-mark=downloadp
add action=mark-connection chain=postrouting comment="HTTPS UP" connection-bytes=0-1000000 dst-port=443   new-connection-mark=httpsupconn out-interface=WAN 1 protocol=tcp
add action=mark-connection chain=postrouting connection-bytes=100000-0 dst-port=443 new-connection-mark= heavyhttpsupconn out-interface=WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=httpsupconn new-packet-mark=httpsup passthrough=no
add action=mark-packet chain=postrouting connection-mark=heavyhttpsupconn new-packet-mark=heavyhttpsup   passthrough=no
add action=mark-connection chain=prerouting comment="HTTPS DOWN" connection-bytes=0-40000000 in-interface= WAN 1 new-connection-mark=httpsdownconn protocol=tcp src-port=443
add action=mark-connection chain=prerouting connection-bytes=40000000-0 in-interface=WAN 1  new-connection-mark=heavyhttpsdownconn protocol=tcp src-port=443
add action=mark-packet chain=prerouting connection-mark=httpsdownconn new-packet-mark=httpsdown passthrough=no
add action=mark-packet chain=prerouting connection-mark=heavyhttpsdownconn new-packet-mark=heavyhttpsdown  passthrough=no
add action=mark-connection chain=postrouting comment="HTTP UP" dst-port=80 new-connection-mark=httpupconn  out-interface=WAN 1 protocol=tcp
add action=mark-connection chain=postrouting connection-bytes=100000-0 dst-port=80 new-connection-mark= heavyhttpupconn out-interface=WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=httpupconn new-packet-mark=httpup passthrough=no
add action=mark-packet chain=postrouting connection-mark=heavyhttpupconn new-packet-mark=heavyhttpup  passthrough=no
add action=mark-connection chain=prerouting comment="HTTP DOWN" connection-bytes=0-1100000 in-interface= WAN 1 new-connection-mark=httpdownconn protocol=tcp src-port=80
add action=mark-connection chain=prerouting connection-bytes=1100000-0 in-interface=WAN 1  new-connection-mark=heavyhttpdownconn protocol=tcp src-port=80
add action=mark-packet chain=prerouting connection-mark=httpdownconn new-packet-mark=httpdown passthrough=no
add action=mark-packet chain=prerouting connection-mark=heavyhttpdownconn new-packet-mark=heavyhttpdown passthrough=no
add action=mark-connection chain=postrouting comment="DNS UP" dst-port=53 new-connection-mark=dnsupconn  out-interface=WAN 1 protocol=tcp
add action=mark-connection chain=postrouting dst-port=53 new-connection-mark=dnsupconn out-interface=  WAN 1 protocol=udp
add action=mark-packet chain=postrouting connection-mark=dnsupconn new-packet-mark=dnsup passthrough=no
add action=mark-connection chain=prerouting comment="DNS DOWN" in-interface=WAN 1 new-connection-mark=dnsdownconn protocol=tcp src-port=53
add action=mark-connection chain=prerouting in-interface=WAN 1 new-connection-mark=dnsdownconn  protocol=udp src-port=53
add action=mark-packet chain=prerouting connection-mark=dnsdownconn new-packet-mark=dnsdown passthrough=no
add action=mark-connection chain=postrouting comment="FTP & SFTP UP" dst-port=20,21,115 new-connection-mark=ftpupconn out-interface=WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=ftpupconn new-packet-mark=ftpup passthrough=no
add action=mark-connection chain=prerouting comment="FTP & SFTP DOWN" in-interface=WAN 1  new-connection-mark=ftpdownconn protocol=tcp src-port=20,21,115
add action=mark-packet chain=prerouting connection-mark=ftpdownconn new-packet-mark=ftpdown passthrough=no
add action=mark-connection chain=postrouting comment="ICMP UP" new-connection-mark=icmpupconn out-interface=WAN 1 protocol=icmp
add action=mark-packet chain=postrouting connection-mark=icmpupconn new-packet-mark=icmpup passthrough=no
add action=mark-connection chain=prerouting comment="ICMP DOWN" in-interface=WAN 1  new-connection-mark=icmpdownconn protocol=icmp
add action=mark-packet chain=prerouting connection-mark=icmpdownconn new-packet-mark=icmpdown passthrough=no
add action=mark-connection chain=postrouting comment="SSH  UP" dst-port=22 new-connection-mark=sshupconn  out-interface=WAN 1 protocol=udp
add action=mark-connection chain=postrouting dst-port=22 new-connection-mark=sshupconn out-interface= WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=sshupconn new-packet-mark=sshup passthrough=no
add action=mark-connection chain=prerouting comment="SSH  DOWN" in-interface=WAN 1  new-connection-mark=sshdownconn protocol=tcp src-port=22
add action=mark-connection chain=prerouting in-interface=WAN 1 new-connection-mark=sshdownconn  protocol=udp src-port=22
add action=mark-packet chain=prerouting connection-mark=sshdownconn new-packet-mark=sshdown passthrough=no
add action=mark-connection chain=postrouting comment="TELNET UP" dst-port=23 new-connection-mark=telnetupconn  out-interface=WAN 1 protocol=tcp
add action=mark-connection chain=postrouting dst-port=23 new-connection-mark=telnetupconn out-interface=    WAN 1 protocol=udp
add action=mark-packet chain=postrouting connection-mark=telnetupconn new-packet-mark=telnetup passthrough=no
add action=mark-connection chain=prerouting comment="TELNET TCP DOWN" in-interface=WAN 1  new-connection-mark=telnetdownconn protocol=tcp src-port=23
add action=mark-connection chain=prerouting in-interface=WAN 1 new-connection-mark=telnetdownconn  protocol=udp src-port=23
add action=mark-packet chain=prerouting connection-mark=telnetdownconn new-packet-mark=telnetdown passthrough= no
add action=mark-connection chain=postrouting comment="EMAIL UP" dst-port=110,995,143,993,25,465,587 new-connection-mark=emailupconn out-interface=WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=emailupconn new-packet-mark=emailup passthrough=no
add action=mark-connection chain=prerouting comment="EMAIL DOWN" in-interface=WAN 1 new-connection-mark=emaildownconn protocol=tcp src-port=110,995,143,993,25,465,587
add action=mark-packet chain=prerouting connection-mark=emaildownconn new-packet-mark=emaildown passthrough=no
add action=mark-connection chain=postrouting comment="P2P UP" new-connection-mark=p2pupconn out-interface= WAN 1 p2p=all-p2p
add action=mark-packet chain=postrouting connection-mark=p2pupconn new-packet-mark=p2pup passthrough=no
add action=mark-connection chain=prerouting comment="P2P DOWN" in-interface=WAN 1  new-connection-mark=p2pdownconn p2p=all-p2p
add action=mark-packet chain=prerouting connection-mark=p2pdownconn new-packet-mark=p2pdown passthrough=no
add action=mark-connection chain=postrouting comment="ACK UP" new-connection-mark=ackupconn out-interface=WAN 1 packet-size=0-123 protocol=tcp tcp-flags=ack
add action=mark-packet chain=postrouting connection-mark=ackupconn new-packet-mark=ackup passthrough=no
add action=mark-connection chain=prerouting comment="ACK DOWN" in-interface=WAN 1 new-connection-mark=ackdownconn packet-size=0-123 protocol=tcp tcp-flags=ack
add action=mark-packet chain=prerouting connection-mark=ackdownconn new-packet-mark=ackdown passthrough=no
add action=mark-connection chain=postrouting comment="SYN UP " new-connection-mark=synupconn out-interface=WAN 1 packet-size=0-666 protocol=tcp tcp-flags=syn
add action=mark-packet chain=postrouting connection-mark=synupconn new-packet-mark=synup passthrough=no
add action=mark-connection chain=prerouting comment="SYN DOWN" in-interface=WAN 1 new-connection-mark=syndownconn packet-size=0-666 protocol=tcp tcp-flags=syn
add action=mark-packet chain=prerouting connection-mark=syndownconn new-packet-mark=syndown passthrough=no
add action=mark-connection chain=postrouting comment="VOIP UP" dst-port= 5060,5061,5004,5005,5010,5521,11000,10000,1719,16384,13392 new-connection-mark=voipupconn out-interface=WAN 1 protocol=udp
add action=mark-connection chain=postrouting dst-port=5082,3478,2427,19295,19302,5243,7985 new-connection-mark=voipupconn out-interface=WAN 1 protocol=udp
add action=mark-packet chain=postrouting connection-mark=voipupconn new-packet-mark=voipup passthrough=no
add action=mark-connection chain=prerouting comment="VOIP DOWN" in-interface=WAN 1 new-connection-mark=voipdownconn protocol=udp src-port=5060,5061,5004,5005,5010,5521,11000,10000,1719,16384,13392
add action=mark-connection chain=prerouting in-interface=WAN 1 new-connection-mark=voipdownconn protocol=udp src-port=5082,3478,2427,19295,19302,5243,7985
add action=mark-packet chain=prerouting connection-mark=voipdownconn new-packet-mark=voipdown passthrough=no
add action=mark-connection chain=postrouting comment="GOOGLE UP" dst-port=5222,5228 new-connection-mark=googleupconn out-interface=WAN 1 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=googleupconn new-packet-mark=googleup passthrough=no
add action=mark-connection chain=prerouting comment="GOOGLE DOWN" in-interface=WAN 1 new-connection-mark=googledownconn protocol=tcp src-port=5222,5228
add action=mark-packet chain=prerouting connection-mark=googledownconn new-packet-mark=googledown passthrough= no
add action=mark-connection chain=postrouting comment="OTHER UP" new-connection-mark=otherupconn out-interface= WAN 1
add action=mark-packet chain=postrouting connection-mark=otherupconn new-packet-mark=otherup passthrough=no
add action=mark-connection chain=prerouting comment="OTHER DOWN" in-interface=WAN 1  new-connection-mark=otherdownconn
add action=mark-packet chain=prerouting connection-mark=otherdownconn new-packet-mark=otherdown passthrough=no


/queue type
set 0 pfifo-limit=500
set 1 pfifo-limit=500000000
add kind=pcq name=PCQ_HITS pcq-burst-time=30s pcq-classifier=src-address,dst-address,src-port,dst-port pcq-dst-address6-mask=64 pcq-src-address6-mask=64 pcq-total-limit=4000
add kind=pcq name=PCQ_UP pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64 pcq-total-limit=20000
add kind=pcq name=PCQ_DOWN pcq-classifier=dst-address pcq-dst-address6-mask= 64 pcq-src-address6-mask=64 pcq-total-limit=20000
add kind=pcq name=Cache-Limit pcq-classifier=dst-address  pcq-dst-address6-mask=64 pcq-src-address6-mask=64 pcq-total-limit= 40000000
add kind=pcq name="NORMAL DOWN" pcq-classifier=dst-address  pcq-dst-address6-mask=64 pcq-limit=100 pcq-src-address6-mask=64 pcq-total-limit=40000
add kind=pcq name="HEAVY DOWN" pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=500 pcq-src-address6-mask=64 pcq-total-limit=200000
add kind=pfifo name="NORMAL HTTP" pfifo-limit=500
set 16 pfifo-limit=500000000



/queue tree
add name=DOWN parent=global queue=PCQ_DOWN
add name=UP parent=WAN 1 queue=PCQ_UP
add name="GOOGLE UP" packet-mark=googleup parent=UP priority=3 queue=default
add name="DNS UP" packet-mark=dnsup parent=UP priority=1 queue=default
add name="DNS DOWN" packet-mark=dnsdown parent=DOWN priority=1 queue=default
add name="ICMP UP" packet-mark=icmpup parent=UP priority=1 queue=default
add name="ICMP DOWN" packet-mark=icmpdown parent=DOWN priority=1 queue= default
add name="TELENET UP" packet-mark=telnetup parent=UP priority=3 queue=default
add name="TELNET DOWN" packet-mark=telnetdown parent=DOWN priority=3 queue=default
add name="SSH UP" packet-mark=sshup parent=UP priority=4 queue=default
add name="SSH DOWN" packet-mark=sshdown parent=DOWN priority=4 queue=default
add name="FTP UP" packet-mark=ftpup parent=UP priority=7 queue=default
add name="VOIP DOWN" packet-mark=voipdown parent=DOWN priority=2 queue=default
add name="EMAIL UP" packet-mark=emailup parent=UP priority=4 queue=default
add name="EMAIL DOWN" packet-mark=emaildown parent=DOWN priority=4 queue=default
add name="SYN UP" packet-mark=synup parent=UP priority=1 queue=default
add name="ACK UP" packet-mark=ackup parent=UP priority=3 queue=default
add name="P2P UP" packet-mark=p2pup parent=UP queue=default
add name="OTHER UP" packet-mark=otherup parent=UP priority=5 queue=default
add name="VOIP UP" packet-mark=voipup parent=UP priority=2 queue=default
add name="P2P DOWN" packet-mark=p2pdown parent=DOWN queue=default
add name="GOOGLE DOWN" packet-mark=googledown parent=DOWN priority=3 queue= default
add name="ACK DOWN" packet-mark=ackdown parent=DOWN priority=3 queue=default
add name="SYN DOWN" packet-mark=syndown parent=DOWN priority=1 queue=default
add name="OTHER DOWN" packet-mark=otherdown parent=DOWN priority=5 queue= default
add name="FTP DOWN" packet-mark=ftpdown parent=DOWN priority=7 queue=default
add name="HEAVY UPLOAD DATA" parent=UP queue=default
add name="NORMAL DOWNLOAD DATA" parent=DOWN priority=6 queue="NORMAL DOWN"
add name="NORMAL UPLOAD DATA" parent=UP priority=6 queue=default
add disabled=yes name="YouTube Download" packet-mark="YouTube Download" parent=DOWN priority=4 queue="HEAVY DOWN"
add name="HEAVY DOWNLOAD DATA" parent=DOWN queue="HEAVY DOWN"
add disabled=yes name="YFaceBook Download" packet-mark="FaceBook Download" parent=DOWN priority=3 queue="NORMAL DOWN"
add name="HTTPS UP" packet-mark=httpsup parent="NORMAL UPLOAD DATA" priority=1 queue=default
add name="HTTPS DOWN" packet-mark=httpsdown parent="NORMAL DOWNLOAD DATA"  priority=1 queue="NORMAL DOWN"
add name="HTTP DOWN" packet-mark=httpdown parent="NORMAL DOWNLOAD DATA"   priority=2 queue="NORMAL DOWN"
add name="HEAVY HTTPS UP" packet-mark=heavyhttpsup parent="HEAVY UPLOAD DATA" priority=3 queue=default
add name="HEAVY HTTP UP" packet-mark=heavyhttpup parent="HEAVY UPLOAD DATA"  priority=4 queue=default
add name="HTTP UP" packet-mark=httpup parent="NORMAL UPLOAD DATA" priority=2 queue=default
add name="HEAVY HTTPS DOWN" packet-mark=heavyhttpsdown parent= "HEAVY DOWNLOAD DATA" priority=3 queue="HEAVY DOWN"
add name="HEAVY HTTP DOWN" packet-mark=heavyhttpdown parent="HEAVY DOWNLOAD DATA" priority=4 queue="HEAVY DOWN"

Entendendo a aba wireless

Bom aqui vai alguns detalhes sobre a configuração do AirOS. Como está resumido, apenas falarei sobre a opção WIRELESS e ADVANCED.
Então começando por WIRELESS:Clique na imagem para uma versão maior Nome: wireless.jpg Visualizações: 468 Tamanho: 5,9 KB ID: 18799

Lembrando que tudo que esta aqui, foi retirado do google, wikipedia, manual do AirOS e ate mesmo do under-linux.org, então se alguém ler o que já escreveu em post anterior, não se assuste, é de sua autoria mesmo.
O objetivo desse post, é colher informações do tipo, como vocês estão utilizando o rocket em modo AP, e como esta configurando. Eu configurei o meu assim, de acordo com que pesquisei, porem não sei ao bem se estou certo. Gostaria que postassem os macetes ou ate mesmo as experiências já presenciadas.
Em Wireless Mode:
Clique na imagem para uma versão maior Nome: mode.jpg Visualizações: 865 Tamanho: 5,5 KB ID: 18800

Como vou utilizar modo Access Point ou Ponto de Acesso, irei selecionar a opção Access Point. Lembrado que estou utilizando um RocketM com uma BaseStation 90.
Em SSID, é o nome da rede desejada, e se slecionar o HIDE SSID, a seu nome da rede ficará oculto para todos, inclusive para outros aparelhos da linha M.
Mode IEEE:

Clique na imagem para uma versão maior Nome: iee.jpg Visualizações: 462 Tamanho: 2,8 KB ID: 18793
Aqui por padrão, o RocketM apenas trabalha em modo A/N Mixed.
Channel Width:

Clique na imagem para uma versão maior Nome: channel.jpg Visualizações: 390 Tamanho: 3,0 KB ID: 18801
Canal Largura: Esta é a largura espectral do canal de rádio. Suportado larguras espectro wireless canal:

  • 5MHz – é o espectro do canal com a largura de 5 MHz (conhecida como Taxa de modo Quarter).
  • 10MHz – é o espectro do canal com a largura de 10 MHz (conhecida como Taxa de modo Half).
  • 20MHz – é o espectro de largura do canal padrão (selecionada por padrão).
  • 40MHz – é o espectro do canal com a largura de 40 MHz.

Reduzir a largura espectral fornece duas vantagens e uma desvantagem.

  • Vantagem 1: Ela vai aumentar a quantidade de canais não-sobrepostos. Isso pode permitir que redes de escala mais
  • Benefício 2: Ela vai aumentar o PSD (densidade espectral de potência) do canal e permitir que a distância apontam para um aumento.
  • Desvantagem: Irá reduzir throughput proporcional à redução do tamanho do canal. Então, só o modo como turbo (40MHz) aumenta as velocidades possíveis em 2x, metade do canal do espectro (10MHz), vai diminuir as velocidades possíveis em 2x.

Channel Shifiting:
Clique na imagem para uma versão maior Nome: shifiting.jpg Visualizações: 383 Tamanho: 3,1 KB ID: 18796

Channel Shifting: opção permite que os canais especiais que têm o desvio de frequência do 802.11b padrão e canais 802.11a. Esta é uma característica Ubiquiti proprietário desenvolvido. Os benefícios são redes privadas e de segurança inerentes. Usando o canal de mudança, as redes podem instantaneamente se tornam invisíveis para os milhões de dispositivos Wi-Fi em todo o mundo.
É como se oculta-se o SSID, porem os produtos da linha M5 da ubiquiti se enxergam, já os outros fabricantes não.
Frequency:

Clique na imagem para uma versão maior Nome: freq.jpg Visualizações: 377 Tamanho: 2,6 KB ID: 18798
Freqüência ou Canal qual o rocket irá trafegar. Faça sempre uma varredura com o AirView, e escolha o canal mais apropriado.
Output Power:

Clique na imagem para uma versão maior Nome: power.jpg Visualizações: 386 Tamanho: 5,2 KB ID: 18797
Quanto menor a força, melhor o troughput e consequentemente qualidade de navegação. Procure trabalhar com 17dbm.
Security:
Clique na imagem para uma versão maior Nome: security.jpg Visualizações: 410 Tamanho: 6,4 KB ID: 18794

Você pode escolher um criptografia, porem não recomendado. O que recomendo é no maximo o cadastro dos MACs dos clientes apontado para essa setorial, evitando que alguém conecte “a toa”.
Ative a opção MAC ACL, e cadastre os MACs que deseja negar ou permitir, dependo do que escolher.

 

por int21 Postado em Ubnt