Script para bloquear Androids na Rede Local

Um cliente me pediu para bloquear somente os androids na rede.

Segue o script que deve ser rodado a cada 5 minutos.

:foreach x in=[/ip firewall filter find comment~”Android”] do={
/ip firewall filter remove $x;
}
:foreach i in=[/ip dhcp-server lease find host-name~”android”] do={
:local android [/ip dhcp-server lease get $i mac-address];
:log error (“Android(s) detectado(s): ” . [/ip dhcp-server lease get $i mac-address])
/ip firewall filter add chain=input action=drop src-mac-address=$android comment=”Android Bloqueado” ;
}

Caso haja necessidade de liberar algum mac para nao ser pego pela liosta segue a gambi:

#Bloquear

:foreach s in=[/ip firewall filter find comment~”Android”] do={
/ip firewall filter remove $s;
}

:foreach j in=[/ip dhcp-server lease find host-name~”android-“] do={
:local android [/ip dhcp-server lease get $j mac-address];
:log error (“Android(s) detectado(s): ” . [/ip dhcp-server lease get $j mac-address])
/ip firewall filter add chain=input action=drop src-mac-address=$android comment=”Android Bloqueado” ;

}

#Liberar mac tal

:foreach r in=[/ip firewall filter find src-mac-address=”C0:65:99:B7:79:53″] do={
/ip firewall filter disable $r;
/ip firewall filter set comment=”Liberado” $r;
}

2 comentários em “Script para bloquear Androids na Rede Local

  1. Boa tarde, estou tentando adaptar este script para limitar a banda dos dispositivos android e nao bloquear eles, Estou usando a versão 6 porem ao executar o script igual
    o do site sem modificaçoes nao acontece nada . Sabe me dizes se esta versão é compativel com a versão 6.X

    • Opa, não usei ele na v 6.x, mas não ha dificuldade nenhuma emimplementar em 6x, o macete é colar o script no terminal e ver onde ele apresenta algum erro e corrigir na mão, qualquer dificuldade me add no skype: celsold

Deixe seu comentário ;)

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s