Scripts para limpar DHCP (android lease)

Estes scripts fazem algumas coisas que eu precisei esta semana como por exemplo, limpar as entradas ANDROID
do lease do dhcp num mikrotik (hotspot) publico que encheu muito rapido.

:foreach i in=[/ip dhcp-server lease find mac-address=00:00:00:00:00:00] do={
:log error (“Mac address zero detectado: ” . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease remove $i;
}

:foreach i in=[/ip dhcp-server lease find status=”busy”] do={
:log error (“Busy status detectado: ” . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease disable $i;
/ip dhcp-server lease enable $i;
}

:foreach i in=[/ip dhcp-server lease find host-name~”android”] do={
:log error (“Removendo entradas android: ” . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease remove $i;
}

:foreach i in=[/ip dhcp-server lease find host-name=””] do={
:log error (“Removendo entradas em branco sem hostname: ” . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease remove $i;
}

9 comentários em “Scripts para limpar DHCP (android lease)

  1. Oi, gostaria de saber como posso aplicar esse script para remover todos os dispositivos do dhcp a cada intervalo de tempo por exemplo? pelo que vi teem que ter o nome do dispositivo, e eu não posso criar tantos scripts

      • Então, eu queria saber para aplicar o script para a remoção de todas as leases a cada intervalo de tempo, ai consegui colocar ele pra remover mudando um pouco do script, ele ficou assim **** foreach i in=[/ip dhcp-server lease find status=”bound”] do={/ip dhcp-server lease remove $i; } ****

Deixe uma resposta para int21 Cancelar resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s